Incidents reported in November 2024

Nov. 25, 2024

Problem with AWS network
Azure Platform
  • Fixed
    We fixed the problem last update 2 weeks, 3 days ago
  • Identified
    We identified the problem and we are fixing it last update 2 weeks, 3 days ago
  • Investigating
    We are experiencing issues with the AWS network last update 2 weeks, 3 days ago